Moparchat - Home of MOPAR enthusiasts worldwide!



Go Back   Moparchat - Home of MOPAR enthusiasts worldwide! > >

Click here to search for Mopar cars and parts for sale.


Reply
 
Thread Tools Display Modes
  #1  
Old 07-12-2019, 03:33 PM
lil red rick lil red rick is offline
Registered User
 
Join Date: Apr 2003
Location: Wellford,SC
Age: 53
Posts: 45
Default Electrical issues galore.

Hey all!
Just had to rent the wife and daughter a car as our 2007 Durango Limited has been possessed!
Itís had all sorts of lights and alarms on it for some months but had driven without issue. Today it cut off in the driveway about 4 times. Had it checked thinking bad battery again but this time they said bad alternator. We replaced that about 3 years ago and the battery twice over the years. Even replaced gas cap as it had a bad one code. Not sure what if any codes itís throwing but traction control light on, gas cap, and about every other light on.
Any ideas where to start?
Thanks, Rick.
Reply With Quote
Reply

Tags
bad , battery , cap , itís , replaced

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




All times are GMT -4. The time now is 12:37 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.
Search Engine Optimisation provided by DragonByte SEO v2.0.37 (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Optimisation provided by vB Optimise (Lite) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
. . . . .