Moparchat - Home of MOPAR enthusiasts worldwide!



Go Back   Moparchat - Home of MOPAR enthusiasts worldwide! > Technical Forums > Neon Club Chat

Click here to search for Mopar cars and parts for sale.


Reply
 
Thread Tools Display Modes
  #1  
Old 10-07-2009, 01:28 AM
stevengill1 stevengill1 is offline
Inactive User
 
Join Date: Oct 2009
Location: castle rock,wa.
Posts: 1
Default broke down

just bought a 1995 neon the speedometer doesn't work, the seller said it needed a dash panel. can't i just replace the cable ? also it start like the choke is stuck closed but i checked it and there is no choke. i haven't worked on cars in years but now i'm out of work and can't afford to go to a mechanic, so if anyone out there can help with mechanical advice it would be greatly appreciated.thank you.
Reply With Quote
  #2  
Old 10-07-2009, 01:52 AM
Dick's Avatar
Dick Dick is offline
Registered User
 
Join Date: Oct 2001
Location: Western NH
Age: 80
Posts: 8,880
Biggrin

This link may help you. The 1995 Neons had cluster problems that could be cured by re-soldering the board.

http://forums.neons.org/viewtopic.php?f=22&t=118450
Reply With Quote
  #3  
Old 10-08-2009, 12:10 AM
JVMopar's Avatar
JVMopar JVMopar is offline
Senior Member
 
Join Date: Feb 2000
Location: Mellen, WI
Age: 43
Posts: 2,524
Default

Dick is right. Take out the cluster and resolder all of the connections. I did it to my sisters Neon. Took about an hour, a solder iron, and some rosin core solder.

First thing to do is check your codes. Cycle the key on and off 3 times on the 3rd time leave the key on and count the check engine light flashes.

example (flash---flash-flash) this is a 12.

From what it sounds like is a leaking injector. I worked on one that would run rough from a cold start but clear out and run fine after it warmed up.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Almost Won, Car Broke sassygtx Circle Track Chat 5 08-23-2008 02:21 PM
broke a$$ gen II tobs440 Dakota Truck Forum 20 07-19-2004 07:19 PM
What broke landyacht67 Polls Forum 5 03-06-2004 11:18 PM
what broke? dusterbd Performance Talk 2 03-21-2002 03:30 PM
I Broke Again.... SubLime440 Performance Talk 3 10-01-2001 06:38 PM




All times are GMT -4. The time now is 06:36 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.
. . . . .