Click here to search for Mopar cars and parts for sale.


Moparchat - Home of MOPAR enthusiasts worldwide!  
Discount Auto Parts

Go Back   Moparchat - Home of MOPAR enthusiasts worldwide! > Technical Forums > Dakota Truck Forum
Register FAQ Members List Calendar Mark Forums Read


Welcome to the Moparchat - Home of MOPAR enthusiasts worldwide! forums.

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.
Reply
 
Thread Tools Display Modes
  #1  
Old 09-13-2017, 07:35 PM
moparman64 moparman64 is offline
Registered User
 
Join Date: Feb 2004
Location: South Carolina
Posts: 51
Default 2006 dakota power steering issue

Working on a 2006 dakota with a 4.7 liter . Complaint was power steering has rough spots when turning. Inspection found fluid leaking from right front seal and dripping from bellow. Installed remand rack and pinion and new steering pump filled with correct fluid. Also flushed reservoir and hoses. Test drove vehicle and it has the same problem. Check tsb from chrysler that stated to pull vacuum on pump with special tool cap on pump reservoir. Pulled to 25 hg vacuum that dropped vacuum several times then held at 25 for overnite. Topped off to correct level and test drove. Still problem is there. Pulled both tie rod ends loose from spindle and can rotate both sides without any binding what so ever. Is it possible that with full weight on vehicle that the extra pressure is causing the lower ball joints to bind when turning. Steering does not seem to be as rough when vehicle is lifted. Any information on this would be greatly appreciated. NOTE: STEERING COLUMN SHAFT DOES NOT SEEM TO BE BINDING .
Reply With Quote
  #2  
Old 09-17-2017, 09:38 AM
JVMopar's Avatar
JVMopar JVMopar is offline
Senior Member
 
Join Date: Feb 2000
Location: Mellen, WI
Age: 36
Posts: 2,506
Default

If you have access to an alignment rack or just the turn plates you could check the front end with weight on the wheels.

I would check the u-joints on the steering shaft. I doubt ball joints would cause your issue.

CV axles could cause a binding while turning if it's a 4wd. And could account for the difference with the vehicle in the air because of the angle change in the CV joints.
__________________
'73 Dodge D200 Camper Special 7500
'86 W350 360/727 '90 W150 318/NP435
'92 Lebaron 2.2L Turbo/ 5spd '92 Dakota 5.9L/A-500
'94 Voyager 2.5L/5spd '94 Sundance 2.2L/5spd Red
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 6 (0 members and 6 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


Want to contribute to Moparchat?  Click below!



All times are GMT -4. The time now is 05:19 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

. . . . .